关于go1.8 plugin.Open的错误

//构建插件
package main

go build -buildmode=plugin
//加载插件
package test

plugin.Open("./aplugin.so")

//出现错误:
plugin.Open: plugin was built with a different version of package runtime

//修改代码:
package main

plugin.Open("./aplugin.so")

正常运行,有时想在其他包下加载怎么办,或者怎么向go开发者提出意见?

共 1 个回复


nulijiabei

等正式版吧,测试版还不稳定 (nljb.net)

# 0